Upgrade
Incident Report for
CarLock
Resolved
We have fixed the issues.
Posted
Mar
18
,
2021
-
06:48
UTC
Update
We are continuing to work on a fix for this issue.
Posted
Mar
17
,
2021
-
16:47
UTC
Identified
Due to the major maintenance this week the system performance might be suboptimal. You may experience delays and trips might not show the correct line.
Posted
Mar
17
,
2021
-
12:25
UTC
This incident affected: CarLock Cloud.
×
Subscribe to Incident
Subscribe to updates for
Upgrade
via . You'll receive .