Mobile network outage
Incident Report for CarLock
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 08:17 UTC
Identified
The issue has been identified and we are issuing a fix.
Posted Nov 09, 2020 - 07:26 UTC
This incident affected: Mobile network.